Invalid Connectivity Error Message when Slicing

Problem: I receive the following error when trying to create slices in my data: “Invalid Connectivity found when slicing cell ### from source zone #…” Solution: With the new option of Polygonal Slice mesh, which is meant to preserve the original mesh structure, invalid meshes create a bad cell in a slice. This is why the error is appearing. In many cases, the slices can be generated when switching to […]

» Read More


Precise Probe to Create Time Series Plot

Problem: How do I Probe to Create Time Series Plot at a given set of coordinates? Solution: Use Tecplot’s macro language to precisely define the point to probe. The commands are as follow: Prompt for the (X, Y, Z) coordinates of the point to probe: $!PROMPTFORTEXTSTRING |xPosition| INSTRUCTIONS = “Enter X position of the probe.” Or define them directly in the macro: $!VARSET |xPosition|= 0.1 Pass these coordinates to the […]

» Read More


Use FFmpeg to create videos from PNGs

Problem: I want to create a movie file from a series of images that I export from Tecplot. Solution:  Tecplot 360 2018 R2.1 introduced the ability to export animations to a series of images. FFmpeg, which is bundled with Tecplot 360, has commands to convert a set of images into a video format. Here is an example command: ffmpeg.exe -framerate 40 -i image%9d.png -s:v 1024×910 -c:v libx264 -profile:v high -crf […]

» Read More


Extract Vortex Cores over time

Problem: How do I extract vortex cores over time? Solution: Use a Tecplot Macro to loop over time and extract the vortex cores at each time step. Make sure Tecplot is aware of the variables representing your velocity field (Analyze->Field Variables menu).   The commands are as follow: Retrieve the number of time steps $!EXTENDEDCOMMAND COMMANDPROCESSORID=’extend time mcr’ COMMAND=’QUERY.NUMTIMESTEPS NUMTIMESTEPS’ Loop over time $!LOOP |NUMTIMESTEPS| $!EXTENDEDCOMMAND COMMANDPROCESSORID=’extend time mcr’ COMMAND=’SET.CURTIMESTEP […]

» Read More


Vortex Core Extraction Method

Problem: How is the Vortex Core calculated in Tecplot 360? Solution: The exact Vortex Core extraction method is defined in an AIAA paper called “Identification of Swirling Flow in 3-D Vector Fields” by David Sujudi and Robert Haimes of the Massachusettes Institute of Technology. Abstract An algorithm for identifying the center of swirling flow in 3-D discretized vector fields has been developed. The algorithm is based on critical point theory and […]

» Read More


Multi-Threading and Parallel Processing

This article will list the different portions of Tecplot 360 that use Multi-Threading and Parallel Processing. Each portion of what is used can be found in the table below: What How CFDA Integration is performed concurrently. Geometry boundary generation is performed concurrently. The following calculated variables are calculated concurrently: Cross Flow Velocity, Density, Dynamic Pressure, Enthalpy, Entropy, Entropy Measure S1, Equivalent Potential Velocity Ratio, Internal Energy, Kinetic Energy, Mach Number, […]

» Read More


Time Strands and the Zone Style dialog

When working with transient datasets, Tecplot implements “Time Strands”. Time Strands are assigned to a group of zones which represent the same object. For simple transient datasets, sometimes only one Time Strand is used. Whereas more complex datasets will implement multiple Time Strands. For example, if you are plotting a jet, typically there will be one Time Strand per wing, one for the fuselage, and one for the tail. Time […]

» Read More



Load Multiple Files at Once with a Macro

Problem: I have many files that need to be loaded into Tecplot but loading them all is tedious. I want to load multiple files at once without having to select each individual file. Solution: For files that only differ by a constant, PyTecplot or macro scripts can be configured to load your datasets quickly and accurately. For example, if you have a directory containing many files: file001.plt file002.plt etc. You […]

» Read More


How do I create radial and theta slices?

Radial slices Compute the equation: {R} = sqrt(X**2 + Y**2) in the Data -> Alter -> Specify Equations dialog.  Turn on iso-surfaces in the Plot Sidebar. Then display an iso-surface of constant R. Theta slices Compute the equation: {Theta} = atan2(X,Y) in the Data -> Alter -> Specify Equations dialog. Then display an iso-surface of constant Theta.  Note that due to a singularity at the origin you may get some strange shapes […]

» Read More