Verifying Surface Normals in Integral Calculations

Problem: How do I verify the direction of my unit surface normal vectors to make the correct integrations? If my surface normals point in an inconsistent direction from one timestep to another, how do I correct the value of my integral? From the User’s Manual: “Integrations involving surface unit normals, such as Mass Flow Rate, and Forces and Moments integration, rely on surface unit normals pointing in a consistent direction. […]

» Read More


Calculate Delta Criterion

Problem: How do I calculate Delta Criterion? Solution: The easiest way to do this is to use a Tecplot Macro to automate the calculation. Calculations are derived from http://www.ctr.maths.lu.se/media/thesis/2013/FMA820.pdf First, make sure Tecplot has established the velocity variables via the Field Variables dialog (Analyze -> Field Variables). Then, play the macro via the Scripting menu. The macro commands are as follows: Calculate the Velocity Gradient tensor. (Can also be calculated […]

» Read More


Calculating Average Normal Velocity to Iso-Surface

Problem: How do I calculate the average normal fluid velocity (or any vector variable) going through an iso-surface? Details: Or stated another way, “I am trying to use a vector dot product with unit normal integration to get the average normal velocity through an extracted iso-surface.”  This question originally relates to this scenario, but it can be used for calculating the average flux though a surface for various cases. Solution: […]

» Read More


Creating Streamtraces on a No-slip Boundary Surface with Multiple Surrounding Volume Zones

Problem: How do I create streamtraces on a no-slip boundary surface with multiple surrounding volume zones? In more detail: In the User’s Manual in the section titled “Surface Streamtraces on No-slip Boundaries”, it describes how to create these surface streamtraces in the context of an ASCII file with one parent (volume) zone. However, if other data file types are used or multiple parent zones, these instructions do not apply. Solution: […]

» Read More


Vortex Core Extraction Method

Problem: How is the Vortex Core calculated in Tecplot 360? Solution: The exact Vortex Core extraction method is defined in an AIAA paper called “Identification of Swirling Flow in 3-D Vector Fields” by David Sujudi and Robert Haimes of the Massachusettes Institute of Technology. Abstract An algorithm for identifying the center of swirling flow in 3-D discretized vector fields has been developed. The algorithm is based on critical point theory and […]

» Read More



How do I create radial and theta slices?

Radial slices Compute the equation: {R} = sqrt(X**2 + Y**2) in the Data -> Alter -> Specify Equations dialog.  Turn on iso-surfaces in the Plot Sidebar. Then display an iso-surface of constant R. Theta slices Compute the equation: {Theta} = atan2(X,Y) in the Data -> Alter -> Specify Equations dialog. Then display an iso-surface of constant Theta.  Note that due to a singularity at the origin you may get some strange shapes […]

» Read More


Calculating a New Variable

Creating a new variable or referencing a variable by name requires surrounding it in curly braces. Variables on the right side of equations may be referenced by two other methods:  First, by the variable index. Second is to use variable assignment letter codes. In this example, we’re using ‘u’ and ‘v’ which represent the variables assigned to the U and V vector components in Plot -> Vector -> Variables dialog.  […]

» Read More


Calculating Aerodynamic Forces and Moments

The most accurate forces and moments are normally those output by your flow solver, which knows details of your solution’s boundary conditions and can use modeling such as turbulent wall functions that Tecplot cannot. If your solver’s calculations are not available, you can use Tecplot’s Analyze/Perform Integration… option with the Forces and Moments integration type. There are cases where you want more control over the calculation, however, so this document […]

» Read More


Determining number of Cells in an Unblanked region

To determine the number of cells in an unblanked region, follow these steps: Define your region of interest by selecting Plot > Blanking > Value Blanking… to bring up the Value Blanking dialog to set your criteria. Anything that is blanked will be excluded in the following calculation. Once you have set your blanking criteria accordingly, generate the variable Cell Volume via the Analyze>Calculate Variables… menu and selecting it from […]

» Read More