Alt key does not work on Mac

Problem: The keyboard functions that require the Alt key do not work on Mac Solution: This is because Apple’s X11 X server does not treat the Command or the Option key as an Alt key (despite the fact that the Option key also says alt on it). The workaround is to add the following command to file /etc/X11/xinit/xinitrc: xmodmap -e keycode 63 = Alt_L This will make the Command key […]

» Read More


Multiple contour legends

Problem: I am using multiple contour variables C1 C2 C3 and C4 in my plot but I can only see the legend for C1. Solution: You must have the Contour Details dialog set to the desired contour variable (C1 C2 C3 C4) when you toggle on the Legend. And that contour variable must be in active use in the plot. If a variable is assigned to a Zone Layer like […]

» Read More


Blanking a corner of plot

Problem: I want to blank my contour plot only in the lower left-hand corner where x < 45 AND y < 30. Solution: You can use equations like the ones below to create a blanking variable equal to 0 only if x < 45 and y < 30. Then you can delete the extra variables {lowerx} and {lowery}. {lowerx} = max (x -45, 0) {lowery} = max (y – 30, […]

» Read More


Animating points

Problem: I have some files with some scatter points animated to move in constant velocity. However, the movie shows relative motion of the scatter points making the animation appear jerky. Solution: The reason the scatter points look like they are moving relative to one another has to do with the way they are drawn on the screen. Any object drawn to the screen will be rounded off to the nearest […]

» Read More


Using old text formatting

Problem: Is there any way to use old text formatting with Tecplot 10? Many of my layouts contain text with the special symbols (~ ` _ and so forth). Solution: You can add a command to the tecplot.cfg file to see the text formatted with Tecplot 9 style: $!Compatibility AllowOldTextFormatting = yes This option will let the user use both formatting types at once. It will show both lines of […]

» Read More


Average of XY Mapping

Problem: In my XY Line plot, I want to show a line for the average value of one of the XY Mappings. Solution: You can have Tecplot calculate and plot the average for a line mapping: In the Mapping Style dialog Copy the line mapping and make sure the copy is shown. On the Curves page, set the Curve Fit for the new mapping to the General Curve Fit (One […]

» Read More


Tecplot 10 is slower than Tecplot 9

Note: This software version is no longer supported. Download the latest release or get a free trial. Problem: For zooming or translating my contour plot, Tecplot 10 is much slower than Tecplot 9. Solution: The difference between Tecplot 10 and Tecplot 9 is that different contour levels are set. Notice what levels Tecplot 10 sets set the same levels in Tecplot 9 and see if that makes Tecplot 9 performance slower. If […]

» Read More


Greek or special character in variable name or text

November 2017 Update: LaTeX Fonts are available in Tecplot 360 2017 Release 3 and later. This gives you the ability to use your installed version of LaTeX to display complex formulae and equations directly on your plots. We test against MiKTeX and TeXLive but should be compatible with other LaTeX engines. Watch the LaTeX video tutorial Problem: Some variable names in my data file include one Greek character or another […]

» Read More


AVI animation files are too large

Problem: I can create AVI files in my Tecplot product with the compression set to Lossless Uncompressed to play on a Linux or Macintosh platform but these files are very large. Is there a way to make them smaller but still able to play on these platforms? Solution: Yes. You can encode the uncompressed AVI files to MPEG4 which reduces the size to a fraction of the uncompressed size while […]

» Read More


Linking with frames Apply Settings to all Frames

Problem: I have several frames in my layout and I set the Within Frame Axis Style to be linked. Then I pressed the button for Apply Settings to All Frames. But when I change the label font for one frame te other frames do not change. Solution: Linking on the Between Frames page of the dialog will cause the changes in one frame to apply to all frames. Linking on […]

» Read More